Clover has indicated that the issue has been resolved; we will continue to monitor the situation. If you have ongoing concerns, please reach out to help@goresero.com
Posted Apr 03, 2025 - 17:06 EDT
Update
We continue to receive additional reports of card processing errors; if you are not already subscribed, we recommend subscribing to status updates from WPS at https://status.watchmanpaymentsystems.com as well.
Posted Apr 03, 2025 - 14:32 EDT
Investigating
We are in communications with Clover regarding reports of intermittent delays causing card processing errors; Clover has not identified a system-wide issue resulting in a performance issue, but we are seeing isolated degraded performance.
Posted Apr 03, 2025 - 14:23 EDT
This incident affected: CampusCloud Payment Services (Clover Credit Card Processing).